"The file contains an incorrect number of columns. Please refer to your coding manual."

A solution for a common problem

1 Like

Sometimes you need to delete columns in your upload file because ViDA thinks there is some data in the columns after BZ (even if you cant see anything in the cells). I click and hold on the column header CA and drag across to the right until maybe 20 columns are selected and then right-click and select delete. Save as a csv file and try uploading that to ViDA. Usually works for me.

1 Like

This solution isn’t working for me. Any other tips on what to do?

Hi Robert, could you attach a sample of your file here? I’ll take a look at it

Greg

This ended up starting to work so not an issue anymore. Thanks!

1 Like

Hi Greg, i uploaded the comma form of csv and i didn’t get any answer not error and not traited so i have no information to analyse

Hi Greg I followed the instructions, but errors continue to appearing when I try to upload the file.

Hi kaouther.machta, I took a quick look in ViDA and I can see your results in there. So perhaps the problem is solved?

Hi n.tinjac, have you tried checking to see if your fields are still all in separate cells? Sometimes they can truncated into the first column with each field separated by a “;”. In this case you need to use the Data>Text to Columns function to fix it

Dear Greg
I already did it, following the instructions of the forum: “The file contains an incorrect number of columns. Please refer to your coding manual.”
And still not working :frowning:

Hi @n.tinjac, if you are based in one of the countries in South America, such as Colombia, where values in a CSV file are separated by a semi-colon (; ) rather than a comma (,), you may need to ensure that your ViDA account settings are correct.

On the ViDA website, click on your name then My profile image

Then under settings, select semi-colon (; ) for the delimiter symbol and comma (,) for the decimal symbol.

Once you have saved the changes, try uploading the file again.

I face the same challenge, i tried the options but still it gives the same results

Hi @mirlaw87,

If you are not based in Latin America, please do not follow my advise above regarding changing the settings of your ViDA account. ViDa users in all other regions should select comma (,) for the delimiter symbol and point (.) for the decimal symbol.

Instead, I suggest you follow Luke’s advice and highlighting the 20 or 30 columns directly to the right of BZ and deleting them. Perhaps also take a look at the upload file specification from this library iRAP Specification, Manuals and Guides - iRAP to make sure the column headers in your file match those in the spec. If it still fails the validation in ViDA, try opening the file in notepad rather than excel and looking for and deleting any misplaced symbols (most likely a comma) to the right of the category code for the school zone crossing supervisor attribute (code 3 unless you have a school present). Resave as a CSV file and try uploading again.

Hi Luke, I try this option but not working for me…and I try to convert the CSV file to Notepad and remove all commas, still I face the same challenge, what option should I give it a try? kindly assist

If you have tried all the suggestions from the thread above and the file will still not upload suggest we get the ViDA support team to take a look. Send the file to us via email and we’ll get them to investigate.

Hi, Luke, can you share the e-mail adress? My file is not working and I would like ViDA’s team took a look on that. Tks.

I think the best way to contact the ViDA support team is by using the ‘Contact Support’ option via the ViDA dashboard

In my case I got the same error and after struggling to get it right, I noted there was a row on top of the one with headings for the columns. I deleted that row and got through. I use a MacBook Pro laptop (apple). In the laptop a file in Numbers format is created for the coding. I converted it to .csv and managed to get on. I shared this response in the chat box at the Q & A session on 17th March 2022.

Respested Sir,
I require assistance. I’m having two problems with results time.

  1. In my results, a working or draft watermark appears, and when I go to my sandbox, the final option is not available.
  2. I have done my coding accurately according to the real condition, but much of my area is in the not applicable section. What is this and how can I correct it?

The watermark shows ‘status’ of your dataset which you can change in the dataset setup however in the sandbox you may not have the option to change the status as Final. This doesn’t affect your results or anything else.

The road length under NA category for motorcyclist and pedestrian is because there is no flow. In the coding you may have considered zero % of motorcyclists and the peak hour pedestrian flow values (across, along DS and along PS) as zero that’s where the model shows no Star Rating.